Compiling MathMod 2.0

 
Post new topic   Reply to topic    K3DSurf forum Forum Index -> MathMod for Linux/Unix
View previous topic :: View next topic  
Author Message
kammon



Joined: 06 Nov 2014
Posts: 5

PostPosted: Fri Nov 07, 2014 5:18 am    Post subject: Compiling MathMod 2.0 Reply with quote

Hi, I am trying to compile MathMod 2.0 on Ubuntu 14.04 but are getting errors.

These are the outputs for qmake; make

Code:
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -I/usr/include/qt5 -I/usr/include/qt5/QtOpenGL -I/usr/include/qt5/QtWidgets -I/usr/include/qt5/QtGui -I/usr/include/qt5/QtCore -I. -I. -o drawingoptions.o ui_modules/drawingoptions.cpp
In file included from ui_modules/editor.h:5:0,
                 from ui_modules/drawingoptions.h:24,
                 from ui_modules/drawingoptions.cpp:21:
./ui_editor.h:13:25: fatal error: QtGui/QAction: No such file or directory
 #include <QtGui/QAction>
                         ^
compilation terminated.


qt-creator is already installed.

Thanks.
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Fri Nov 07, 2014 5:41 am    Post subject: Reply with quote

Hi,
It looks like a missing lib in your installation.
It compile fine for me with Ubuntu 14.4 LTS 64bit
Please try to unnstall Qt4 and reinstall Qt5, check this link: https://github.com/splintermind/Dwarf-Therapist/issues/27
Quote:
I was able to build successfully after purging qt4 packages, reinstalling qt5 again, then checking out the DF2014 branch in this repo:

sudo apt-get remove --purge qt4-default qt4-designer qt4-dev-tools qt4-qmake qt4-doc qt4-linguist-tools qtchooser
sudo apt-get install qt5-qmake qt5-default qttools5-dev-tools libqt5script5 libqt5scripttools5 qtscript5-dev


_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
kammon



Joined: 06 Nov 2014
Posts: 5

PostPosted: Fri Nov 07, 2014 7:06 am    Post subject: Reply with quote

Hmm.. I am wondering if there is another way because if I purge qt4 I would purge a lot of things which I would have to reinstall/recompile.
Back to top View user's profile Send private message
kammon



Joined: 06 Nov 2014
Posts: 5

PostPosted: Fri Nov 07, 2014 12:53 pm    Post subject: Reply with quote

Hi, turns out that you don't need to remove the qt4 libs, just install the qt5 libraries following the second command then it will compile.

I think it would be very helpful if you can include that along with the build instructions in the readme file.

Thanks for the help and the great software. Smile
Back to top View user's profile Send private message
kammon



Joined: 06 Nov 2014
Posts: 5

PostPosted: Sat Nov 08, 2014 12:22 am    Post subject: Reply with quote

Hi,

Since I was having the feeling that installing a lot of qt-5 libs may somehow mess up other software I have compiled MathMod in a spare installation on an external hd and then moved the folder to my actual work installation and it works without those qt-5 libs.

After some testing on the spare system (where the qt-5 libs are installed) I can confirm the presence of these qt-5 libs had other undesirable side effects. e.g compiling vlc resulting in systray icon in the wrong place and other weird effects that render vlc almost unusable.

Since these problematic qt-5 libs are only needed to compile MathMod but not to run it (as I am able to on the system without them) I am wondering whether it is possible for you to offer a pre-compiled version for Linux, that will be very helpful. I can imagine people installing these qt-5 libs just to compile MathMod then run into problems later in unexpected places without knowing what bites them.

Thanks.
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Sat Nov 08, 2014 12:24 am    Post subject: Reply with quote

Hi,
You`re welcome. The problem with Linux is that installing Qt5 is Distro- dependant. I'll include a notice to check if Qt5 dev is installed before trying to compile MathMod.
_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Sat Nov 08, 2014 12:27 am    Post subject: Reply with quote

Quote:
Since these problematic qt-5 libs are only needed to compile MathMod but not to run it (as I am able to on the system without them) I am wondering whether it is possible for you to offer a pre-compiled version for Linux, that will be very helpful. I can imagine people installing these qt-5 libs just to compile MathMod then run into problems later in unexpected places without knowing what bites them.

Sure I`ll post it soon in Sourceforge Smile
_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Sat Nov 08, 2014 12:44 am    Post subject: Reply with quote

Hi,
MathMod-2.0 for Linux64 (MathMod-2.0-Ubuntu64.zip) is available for download from:
https://sourceforge.net/projects/mathmod/files/MathMod-2.0/
It should work with most Linux64 Distribution
_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
kammon



Joined: 06 Nov 2014
Posts: 5

PostPosted: Sat Nov 08, 2014 1:09 am    Post subject: Reply with quote

Thanks! Very Happy
Back to top View user's profile Send private message
xedef



Joined: 16 Jul 2014
Posts: 8

PostPosted: Sun Nov 09, 2014 9:54 am    Post subject: OSX? Reply with quote

Any chance to see the mac osx version soon?
Thanks
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Sun Nov 09, 2014 4:33 pm    Post subject: Reply with quote

Hi xedef,
Working on it...should not take too long Smile
_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
nextstep
Site Admin


Joined: 06 Jan 2007
Posts: 538

PostPosted: Thu Nov 13, 2014 6:32 am    Post subject: Reply with quote

Hi,
Please check this link for MathMod-2.0 Mac version:
http://sourceforge.net/projects/mathmod/files/MathMod-2.0/MathMod-2.0-Mac64.zip/download
_________________
Cheers,
Abderrahman
Back to top View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    K3DSurf forum Forum Index -> MathMod for Linux/Unix All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


2005 Powered by phpBB © 2001, 2005 phpBB Group


Start Your Own Video Sharing Site

Free Web Hosting | Free Forum Hosting | FlashWebHost.com | Image Hosting | Photo Gallery | FreeMarriage.com

Powered by PhpBBweb.com, setup your forum now!
For Support, visit Forums.BizHat.com